re = /^Soldto:(?:.*\R){2}\K((?:(?!\s{2}).)+)\K\s*\K((?:(?!\s{2}).)+)/m
str = 'Soldto: Shipto: Billto:
00011222 00017872 10221060
COSTCO CO INC. - GLOBAL EDI COSTCO LANGLEY DEPOT COSTCO CO/LANGLEY
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end