const regex = /(?:[0-9A-F]{2}[:]){5}(?:[0-9A-F]{2})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[0-9A-F]{2}[:]){5}(?:[0-9A-F]{2})', 'gmi')
const str = `ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}