package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:{)([^}]*)(?:})`)
var str = `SELECT * FROM {token1} WHERE {token2}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}