$re = '/(?:{)([^}]*)(?:})/';
$str = 'SELECT * FROM {token1} WHERE {token2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);