using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ChA([0-9])\*ChB([0-9])>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\n";
string input = @"<ChA1*ChB4>*<stopped>*<internal>*<70047272>*<00:00:00>*<00:00:00>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}