re = /<ChA([0-9])\*ChB([0-9])>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\n/
str = '<ChA1*ChB4>*<stopped>*<internal>*<70047272>*<00:00:00>*<00:00:00>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end