import Foundation
let pattern = #"<ChA([0-9])\*ChB([0-9])>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<ChA1*ChB4>*<stopped>*<internal>*<70047272>*<00:00:00>*<00:00:00>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)