using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\b[^>]*src\s*=\s*""cid[^""]*""[^>]*>";
string substitution = @"";
string input = @"In other words <img src = ""http://example.com/images/someimage.jpg""> needs to stay. But, <img src = ""cid:ii_id8bx9qh0_14f205b0a5e7738a""> needs to go. ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}