use strict;
my $str = 'In other words <img src = "http://example.com/images/someimage.jpg"> needs to stay. But, <img src = "cid:ii_id8bx9qh0_14f205b0a5e7738a"> needs to go. ';
my $regex = qr/<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";