$re = '/<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>/mi';
$str = 'In other words <img src = "http://example.com/images/someimage.jpg"> needs to stay. But, <img src = "cid:ii_id8bx9qh0_14f205b0a5e7738a"> needs to go. ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;