# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+?snuffs out the (\d+).. fire pit, and in seconds.+/Bridge $1/g;t' <<< "\#58FAACQaaron snuffs out the 1st fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 2nd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 3rd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 4th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 5th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 6th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 7th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 8th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 9th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 10th fire pit, and in seconds the connecting bridge will also be extinguished!"