using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?snuffs out the (\d+).. fire pit, and in seconds.+";
string substitution = @"Bridge $1";
string input = @"\#58FAACQaaron snuffs out the 1st fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 2nd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 3rd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 4th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 5th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 6th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 7th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 8th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 9th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 10th fire pit, and in seconds the connecting bridge will also be extinguished!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}