package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$(.*):([^$]*)`)
var str = `$Label1: Text1
Text1 possibly continues
$Label2: Text2
$Label3: Text3
Text3 possibly continues`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}