import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(.*):([^$]*)";
final String string = "$Label1: Text1\n"
+ " Text1 possibly continues \n"
+ "$Label2: Text2\n"
+ "$Label3: Text3 \n"
+ " Text3 possibly continues";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}