# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!00[1-9])0/2/gm;t' <<< "0666777888
00034666777888
0034666777888
\"Date\" :0"