#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!00[1-9])0"
Local $sString = "0666777888" & @CRLF & _
"00034666777888" & @CRLF & _
"0034666777888" & @CRLF & _
"" & @CRLF & _
""Date" :0"
Local $sSubst = "2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)