import Foundation
let pattern = #"^(?!00[1-9])0"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0666777888
00034666777888
0034666777888
"Date" :0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)