using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!CT)\d{2}";
string input = @"CT27-ED R
CT27-CD N
CT40-ED R
CT24-CD R
Feeder
Bolter Boom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}