const regex = new RegExp('^(?!_)\\w+(?:[.-]\\w+)*(?<!_)@[^\\W_]+(?>[.-]?\\w*[^\\W_])*\\.[^\\W_]{2,}$', 'gm')
const str = `jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}