using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$";
string input = @"abc
123
abc_123
123-blah_hello
_abc
-123
abc__123
def_-456
abc_
123-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}