const regex = /^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$', 'gm')
const str = `abc
123
abc_123
123-blah_hello
_abc
-123
abc__123
def_-456
abc_
123-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}