re = /^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$/m
str = 'abc
123
abc_123
123-blah_hello
_abc
-123
abc__123
def_-456
abc_
123-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end