$re = '/(FAIL|OK)$/';
$str = '2019-08-02 07:33:32 ---> OK
2019-08-02 08:32:42 ---> FAIL
2019-08-02 09:29:31 ---> OK
2019-08-02 10:29:23 ---> FAIL
2019-08-02 11:31:45 ---> OK
2019-08-02 12:30:55 ---> OK
2019-08-02 13:29:14 ---> FAIL
2019-08-02 14:29:19 ---> OK
2019-08-02 15:31:28 ---> OK
2019-08-02 16:28:39 ---> OK
2019-08-02 17:27:46 ---> OK
2019-08-03 05:28:31 ---> FAIL
2019-08-05 10:27:37 ---> OK
2019-08-05 11:26:39 ---> OK
2019-08-03 05:28:31 ---> FAIL';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);