package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+|\[([\w\s]+)\]`)
var str = `dyson [salisbury matheson beaumont] clarke [carstairs morden] vaughan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}