$re = '/(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].)(\s)(and)(\s)(.+?)(\s)([A-Z].[A-Z].)/';
$str = 'Blois J.L., Zarnetske P.L., Fitzpatrick M.C. and Finnegan S.B.';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;