$re = '/\b[\dA-F]{8}-[\dA-F]{4}-[\dA-F]{4}-[\dA-F]{4}-[\dA-F]{12}-\d+/i';
$str = 'id=1 name=4a3779ab-56cc-41b5-ac7c-03bbf673439c-53607.jpg count=53607';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);