$re = '/^(?=.{8,}$)(?:[^A-Z\n]*[A-Z][^A-Z\n]*|(?:[^A-Z\n]*[A-Z]){6}.*)$/m';
$str = 'AAAAAAaa
AAaaAAaaAVA
Aaaaaaaa
AAAAAAaa
AAaaaaaa ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);