using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*?"")|""";
string substitution = @"\1";
string input = @"title:""no spacing before"" and text breaks ""
title:""no spacing before"" and text breaks "" after this
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}