package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^#:]+):([^#]+)`)
var str = `SiteId:BLR232#Latitude:12.918444#Longitude:77.5940136#NetworkType:4g#Type:NONE#Type of Complaint:Call Drop#Sample Number:7022979575#Problem Description:agshjs vshsijsb#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}