$re = '/^[a-zA-Z](?:\.[A-Za-z0-9._]|[A-Za-z0-9_-]|)+\.?@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b/m';
$str = 'test@gmail.com
w-d@sdf.com
w.d@sdf.com
w.-d@sdf.com
w-d.@sdfcom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);