$re = '/(\bips[uü]\b)/im';
$str = 'lorem ipsüm dolor ipsum dolor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);