re = /\+971\s[0-9]{3}-[0-9]{6}/
str = '+971 556-123456
+996 556-123456
+971 556-123896
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end