using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"td class="".*?stat-last"">.*?<div class=""statnum"">(.*?)<";
string input = @"<table class=""profile-stats"">
<tr>
<td class=""stat"">
<div class=""statnum"">8</div>
<div class=""statlabel""> Tweets </div>
</td>
<td class=""stat"">
<a href=""/THEDJMHA/following"">
<div class=""statnum"">13</div>
<div class=""statlabel""> Following </div>
</a>
</td>
<td class=""stat stat-last"">
<a href=""/THEDJMHA/followers"">
<div class=""statnum"">22</div>
<div class=""statlabel""> Followers </div>
</a>
</td>
</tr>
</table>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}