package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)cause \(.*?(\d+)\)`)
var str = `05/19/2014, 15:24:14.455> LVL:2 RC: 0 SERVER :server main: TERA_MGMT_SYS_SESS_EVENT_RESET with disconnect cause (0x105)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}