$re = '/cause \(.*?(\d+)\)/m';
$str = '05/19/2014, 15:24:14.455> LVL:2 RC: 0 SERVER :server main: TERA_MGMT_SYS_SESS_EVENT_RESET with disconnect cause (0x105)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);