const regex = /\<img.*?width=\"(.*?)\".*?\/?\>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<img.*?width=\\"(.*?)\\".*?\\\/?\\>', 'g')
const str = `<img asdasd width="234.4"hjbsd>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);