use strict;
my $str = '<img asdasd width="234.4"hjbsd>';
my $regex = qr/\<img.*?width=\"(.*?)\".*?\/?\>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";