$re = '/\<img.*?width=\"(.*?)\".*?\/?\>/';
$str = '<img asdasd width="234.4"hjbsd>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;