using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml";
string input = @"
so.addVariable(""playlist"", ""http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml"");
so.addVariable(""autoplay"", ""false"");
// ]]>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}