import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/)?(www\\.)?salvavinilos\\.org\\/.*\\/playlist\\.xml";
final String string = "\n\n"
+ " so.addVariable(\"playlist\", \"http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml\");\n"
+ " so.addVariable(\"autoplay\", \"false\");\n\n"
+ " // ]]>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}