package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^$|(http(s)?:\/\/)([\w-]+\.)+[\w-]+([\w- ;,.\/?%&=]*))`)
var str = `http://www.google.com/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}