use strict;
my $str = 'car
house
home
computer
go
went';
my $regex = qr/[\r\n]+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";