use strict;
my $str = 'blue,black,red
blue,black,red,yellow';
my $regex = qr/^([^,]*),([^,]*),/mp;
my $subst = '\\1:\\2:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";