package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{1:.*\{2:.*\{3:.*\{4:.*`)
var str = `{1:F21CITICCIMMBL0107000001}{2:O2991405210107CITILUL0MBL01070000012101071405N}{3:{108:0000000000000114}}{4:
:20:401648471
:21:FT-TRN1234567890
:79:/ACK/Response Code 200
SCAR Response
Received
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}