const regex = /^((?:[^,]+,\s+){9})[^,]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[^,]+,\\s+){9})[^,]+', '')
const str = `value1, value2, value3, value4, value5, value6, value7, value8, value9, value10`;
const subst = `$1x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);