use strict;
my $str = 'value1, value2, value3, value4, value5, value6, value7, value8, value9, value10';
my $regex = qr/^((?:[^,]+,\s+){9})[^,]+/p;
my $subst = '$1x';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";