import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|^)(?:\\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?|\\d{1,3}(?:.\\d{3})*(?:\\,\\d+)?)(?=\\s|$)";
final String string = "999,999.99\n"
+ "99,999.22\n"
+ "999.999,99\n"
+ "999.999.23,21\n"
+ "99.999,22\n"
+ "13342,4234,123.23\n"
+ "999,222.334552\n"
+ "9,234.24\n"
+ "2,1\n"
+ "111,22.113\n"
+ "1,3\n"
+ "111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}