$re = '/^\d*(\.\d{2})?$/m';
$str = '1000
1000.00
1,000.00
1,000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);