package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\.*: (.+)`)
var str = `domain.............: iltalehti.fi
status.............: Registered
>>> Last update of WHOIS database: 22.3.2020 11:30:05 (EET) <<<`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}