re = /^(.*?)\.*: (.+)/m
str = 'domain.............: iltalehti.fi
status.............: Registered
>>> Last update of WHOIS database: 22.3.2020 11:30:05 (EET) <<<'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end